Saturday, August 09, 2008

Subversion 1.5 in Ubuntu Hardy

While I was trying to reinstall my madwifi driver in Hardy on the Mac, I had to use this command:

sudo svn co madwifi

However, this time I got this error message:
svn: This client is too old to work with working copy 'madwifi'; please get a newer Subversion client

Puzzling, as I had the latest version of subversion that was available in the Ubuntu repos (1.4.6).
In googling around, I came across this post which explained what the problem was (basically there's a new version 1.5 which is available in the Ubuntu Intrepid repo but NOT in Hardy).
Unfortunately, the repos in this post don't work (at least, they didn't for me). However, I came across this thread that discusses the same problem. The repos shown in post#3 work fine. here they are:
deb hardy main
deb-src hardy main

No comments:

Post a Comment